PTA 01-复杂度2 Maximum Subsequence Sum

PTA 01-复杂度2 Maximum Subsequence Sum

题目描述

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

输入格式

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

输出格式

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

输入输出样例

输入样例#1
10
-10 1 2 3 4 -5 -23 3 7 -21
输出样例#1
10 1 4

题目思路

用在线处理的思想来解决,新输入进来的数加到now中,如果now<0,则将now置0,如果now大于max的值就将now赋给max。max置-1用来防止0为最大值,start为当前开始的坐标,rstart为最大值的开始的坐标。

#include<iostream>
using namespace std;
const int N = 1e4+10;
int a[N];
int main()
{
    int t;
    cin >> t;
    int now = 0,max = -1,start=0,rstart=0,end=t-1;
    for(int i=0;i<t;i++)
    {
        cin >> a[i];
        now += a[i];
        if(now > max){
            max = now;
            rstart = start;
            end = i;
        }
        if(now < 0){
            now = 0;
            start = i + 1;
        }
    }
    if(max == -1){
        max = 0;
    }
    cout << max << " " << a[rstart] << " " << a[end];
    return 0;
}

原文链接: https://www.cnblogs.com/fsh001/p/13234085.html

欢迎关注

微信关注下方公众号,第一时间获取干货硬货;公众号内回复【pdf】免费获取数百本计算机经典书籍;

也有高质量的技术群,里面有嵌入式、搜广推等BAT大佬

    PTA 01-复杂度2 Maximum Subsequence Sum

原创文章受到原创版权保护。转载请注明出处:https://www.ccppcoding.com/archives/362357

非原创文章文中已经注明原地址,如有侵权,联系删除

关注公众号【高性能架构探索】,第一时间获取最新文章

转载文章受原作者版权保护。转载请注明原作者出处!

(0)
上一篇 2023年3月2日 下午2:19
下一篇 2023年3月2日 下午2:20

相关推荐