1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
 

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
 

Sample Output:

SC3021234 CS301133


#include<bits/stdc++.h>
using namespace std;
int main(){
    string a,b;
    int rec,in=24*60*60,out=0;
    scanf("%d",&rec);
    while(rec--){
        string str;
        int h,hh,m,mm,s,ss;
        cin>>str;
        scanf("%d:%d:%d %d:%d:%d",&h,&m,&s,&hh,&mm,&ss);
        int i=h*60*60+m*60+s;
        int j=hh*60*60+mm*60+ss;
        if(i<in){
            in=i;
            a=str;
        }
        if(j>out){
            out=j;
            b=str;
        }
    }
    cout<<a<<" "<<b<<endl;
    return 0;
}

 

原文链接: https://www.cnblogs.com/LS-Joze/p/13336901.html

欢迎关注

微信关注下方公众号,第一时间获取干货硬货;公众号内回复【pdf】免费获取数百本计算机经典书籍;

也有高质量的技术群,里面有嵌入式、搜广推等BAT大佬

    1006 Sign In and Sign Out (25分)

原创文章受到原创版权保护。转载请注明出处:https://www.ccppcoding.com/archives/368069

非原创文章文中已经注明原地址,如有侵权,联系删除

关注公众号【高性能架构探索】,第一时间获取最新文章

转载文章受原作者版权保护。转载请注明原作者出处!

(0)
上一篇 2023年3月2日 下午6:13
下一篇 2023年3月2日 下午6:13

相关推荐