Disease Manangement 疾病管理

题目描述

Alas! \(A\) set of \(D (1 <= D <= 15)\) diseases (numbered \(1..D\)) is rshning through the farm. Farmer John would like to milk as many of his N \((1 <= N <= 1,000)\) cows as possible. If the milked cows carry more than K \((1 <= K <= D)\) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

输入格式

  • Line 1: Three space-separated integers: \(N, D, and K\)
  • Lines 2..N+1: Line \(i+1\) describes the diseases of cow \(i\) with a list of 1 or more space-separated integers. The first integer, \(d_i\) , is the cosht of cow \(i"s\) diseases; the next \(d_i\) integers enumerate the actual diseases. Of course, the list is empty if \(d_i\) is 0.
    有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

输出格式

Line 1: M, the maximum number of cows which can be milked.

样例

样例输入

6 3 2
0---------第一头牛患0种病
1 1------第二头牛患一种病,为第一种病.
1 2
1 3
2 2 1
2 2 1

样例输出

5

OUTPUT DETAILS

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two diseases (#1 and #2), which is no greater than K (2).

题解

emmm,状压dp。

code

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
const int maxn=1200;
int lim[maxn];
int f[1<<16];
int find(int x){
    int cnt=0;
    while(x){
        x-=x&(-x);
        cnt++;
    }
    return cnt;
}
int main(){
    int n,m,k;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=n;i++){
        int t;
        scanf("%d",&t);
        while(t--){
            int a;
            scanf("%d",&a);
            lim[i]|=1<<a-1;
        }
    }
    int Mx=1<<m,ans=0;
    for(int i=1;i<=n;i++)
        for(int s=Mx-1;s;s--){  
            f[s|lim[i]]=max(f[s|lim[i]],f[s]+1);
            if(find(s|lim[i])<=k)ans=max(ans,f[s|lim[i]]);
            //printf("%d %d\n",s|lim[i],f[s|lim[i]]);
        }
    printf("%d\n",ans);
}

原文链接: https://www.cnblogs.com/hellohhy/p/13198577.html

欢迎关注

微信关注下方公众号,第一时间获取干货硬货;公众号内回复【pdf】免费获取数百本计算机经典书籍;

也有高质量的技术群,里面有嵌入式、搜广推等BAT大佬

    Disease Manangement 疾病管理

原创文章受到原创版权保护。转载请注明出处:https://www.ccppcoding.com/archives/359721

非原创文章文中已经注明原地址,如有侵权,联系删除

关注公众号【高性能架构探索】,第一时间获取最新文章

转载文章受原作者版权保护。转载请注明原作者出处!

(0)
上一篇 2023年3月2日 下午12:52
下一篇 2023年3月2日 下午12:54

相关推荐